Angular Data GridVersion Compatibility

angular logo

Listed below are the version compatibility requirements for AG Grid if they exist.

AG Grid & Angular Compatibility Chart

The table below gives the ranges of compatible versions of AG Grid with Angular versions.

AngularAG Grid
16 - 17+28 - 31+
14 - 1525 - 31
12 - 1325 - 30
10 - 1124 - 27
923 - 27
818 - 27
6 - 718 - 22

Future Support of Angular versions

AG Grid currently supports Angular v14 and above. Future versions of AG Grid will support the last minor of the Angular Long-term (LTS) version at the time of release. See Angular Support policy and schedule.

Migration to AG Grid v28+

Angular v12+

To migrate applications on Angular v12+ to AG Grid v28+ requires no dependency changes. There are breaking changes, notably AgGridModule no longer supports .withComponents() as it is not required any more.

@NgModule({
    imports: [
-         AgGridModule.withComponents([SquareComponent]),
+         AgGridModule,
    ]
})

Notes on Angular 12+

If using Angular 12+ and versions of AG Grid up to v27 the following warning may be present in the build output. To avoid this, upgrade to at least v28 of AG Grid which is published as an Ivy distribution.

Generating browser application bundles (phase: setup)...
Processing legacy "View Engine" libraries:
- ag-grid-angular [es2015/esm2015]
Encourage the library authors to publish an Ivy distribution.

Notes on Angular Components 10-11

If you are using Angular v10-11 and have Ivy disabled via enableIvy: false then you must declare your custom components with the AgGridModule via the withComponents method. This enables AG Grid to be able to use your Angular components by adding them as entryComponents for you. You need to provide them in the top level NgModule:

@NgModule({
    imports: [
        BrowserModule,
        AgGridModule.withComponents(
            [
                SquareComponent,      // Components to be used within the Grid
                CubeComponent,
                // ...other components
            ]
        ),
    ]
})

Notes on Angular 10

Due to a breaking change in Angular 10 you may experience the following error when building: Generic type 'ModuleWithProviders<T>' requires 1 type argument(s)

If you wish to use Angular 10 with AG Grid versions 18-23 then you need to set "skipLibCheck": true in tsconfig.app.json Please note however that this is a workaround and Angular 10 is only officially supported with AG Grid 24+.